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INTRODUCTION

Welcome to the BERNINA 990 Embroidery Work-

book  In the following exercises, you will become 

familiar with machine embroidery and how to use 

the B 990  Learning to use the B 990 to its fullest 

capabilities will ensure you love your machine for 

many years to come 

It is highly recommended to work through the activ-

ities in this workbook in sequential order, without 

skipping any lessons, at least once  Once you have 

completed all the exercises, keep this workbook 

as a reference guide as you use your machine and 

explore the creative possibilities  Then, after a period 

of using your machine, come back to the exercises 

again to reaffirm the knowledge you have been 

putting into practice  Revisiting the lessons regularly 

will cement your confidence in machine embroidery, 

as well as the BERNINA 990 

Sew at your own pace  You can also follow along 

the BERNINA 990 Skill Hub online course for helpful 

videos and unique learning tools  In addition to the 

workbooks, online course, and classes from your 

BERNINA dealer, there are many instructional videos 

and tutorials built directly into the machine   

Instructional video tutorials are available on the 

bernina com website and the BERNINA International 

YouTube channel too  You will also find inspiring 

sewing projects and eBooks on the BERNINA website 

at bernina com in the Learn & Create section 

http://bernina.com
https://www.youtube.com/user/berninainternational
https://www.youtube.com/user/berninainternational
https://www.bernina.com/en-US/Learn-Create-US
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Chapter I 

PREPARING FOR EMBROIDERY

EXERCISE MATERIALS

Fabric & Stabilizer

• Cut (3) 10” x 15” dark-colored woven fabric 

• Cut (3) 10” x 15” sheets of stabilizer

Notions

• Temporary adhesive spray

• Chalk

• Straightedge ruler

• Various colors of embroidery thread

Hoops & Presser Feet

• Large Oval Embroidery Hoop 

• Embroidery Foot #26L

SETTING UP THE MACHINE

When the embroidery module is attached, the B 990 

will automatically start in Embroidery Mode when 

the machine is turned on  If you have been sewing 

and then wish to embroider, select Embroidery Mode 

from the Home Screen or using the Shortcut icon  

When in Embroidery Mode, the B 990 will automat-

ically lower the feed dog 

Main Menu » Home » Embroidery

Review the manual and/or the following video 

references to attach the module and prepare for 

embroidery 

Set Up the Machine

In this video, learn how to change your 

presser foot and stitch plate, activate 

Dual Feed, add the Slide-on table, and 

set up the Foot Control and Free Hand 

System Lever  

Thread the Machine

Learn how to thread your bobbin and 

needle in this tutorial   

Embroidery Mode Settings

This video explains the settings you’ll 

need for working in embroidery mode, 

such as Upper Thread Tension, Embroi-

dery Speed, Design Position, Hoop Cali-

bration and more 

Attach the Module

This tutorial walks you through attaching 

the embroidery module to the machine  

You’ll also move through important 

aspects of the embroidery interface 

FEATURE FOCUS

Automatic Stitch Plate Detection

The BERNINA 990 will 

automatically recog-

nize the stitch plate 

attached  If you select 

a stitch that is incom-

patible with a partic-

ular stitch plate (for 
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example, a zig-zag stitch with the straight stitch 

plate attached), the machine will show the stitch 

in red to indicate that it cannot complete the stitch 

with the existing plate  You will see an indication of 

which stitch plate is attached in the Status Bar on 

the left-hand side of the machine screen 

HOOPS

Setting up the Hoop and Stabilizer

For each exercise, use the Large Oval Hoop, a 10” x 

15” piece of fabric, and 10” x 15” piece of stabilizer 

1  Separate the inner and outer rings of the 

embroidery hoop 

2  Loosen the screw  It should be loose enough 

that fabric and stabilizer both will EASILY fit 

into the hoop 

3  Lay the outer hoop on a hard, flat surface 

4  Secure stabilizer to the back of the fabric by 

lightly spraying the stabilizer (not the fabric) 

with temporary adhesive spray  Adhere the 

stabilizer to the back of the fabric 

5  Place fabric and stabilizer on a firm surface 

6  Grasping both inner hoop and fabric/stabi-

lizer, lift and insert them into the outer hoop, 

making sure that the arrows align at the 

edges of both the inner and outer hoops  

7  Tighten the screw on the hoop, but DO NOT 

DISTORT THE FABRIC as you do so  Hooped 

fabric should be taut, but not stretched or 

distorted (Fig  1)  Do not tug on the fabric to 

get rid of bubbles or to get the fabric taut  

Re-hoop as needed until it has been hooped 

sufficiently 

Attaching the BERNINA Hoop

Pre-selection

If a hoop is not already attached to the module, you 

can select a hoop beforehand 

1  Select the Hoop Selection icon from the 

Status Bar 

2  Scroll through the options with your stylus or 

finger and select Large Oval Hoop (Fig  2) 

Fig. 1 Fig. 2   
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Attaching Hoop to the Module

Do not attach the hoop to the machine until 

prompted by the machine to do so 

1  Hold the hoop, with the right side of the 

fabric facing up and the attaching mecha-

nism to the left, and position underneath the 

presser foot 

2  Squeeze both attaching mechanisms toward 

each other 

3  Position the hoop above the bracket of the 

module’s embroidery arm 

4  Press down until the hoop clicks into place 

5  Release the attaching mechanisms 

The hoop is automatically recognized by the machine, 

indicated by the selected hoop showing in yellow in 

the Status Bar and in the Hoop Menu, the Selected 

Hoop will show a dark background 

Removing the Hoop

1  Squeeze both attaching mechanisms of the 

hoop toward each other 

2  Remove the hoop 

FEATURE FOCUS

Re-positioning the Hoop

You can reposition an 

embroidery hoop with the 

Hoop Relocation icon  

• Centered: Hoop moves to center for easier 

threading of the needle 

• Sewing Position: Arm moves to the left 

center so you may remove the embroidery 

module (you will be prompted to remove 

the hoop) 

• At the Rear: Hoop moves to the back for 

easy access to the bobbin 
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ESSENTIAL NAVIGATION

In this section, learn about how to adjust the 

embroidery settings on the machine and how to 

work with embroidery designs 

EMBROIDERY SETTINGS

Embroidery Settings can be accessed by selecting 

the Main Menu, then selecting Settings  Next, select 

“Embroidery” to view embroidery settings (fig  3) 

Main Menu » Settings  » Embroidery 

• Upper Thread Tension: This sets the tension 

up or down for all embroidery designs  The 

default tension will work for most projects  

This should only be used if you find an adjust-

ment is needed 

• Embroidery Speed: Sets the maximum 

embroidery speed  The default is 1000 SPM, 

which is the max for the B 990  However, you 

can reduce the speed if you prefer to always 

stitch slower 

• Design Position: The default position is 

“Center of Hoop”  If you are transferring 

designs to and from BERNINA Embroidery Soft-

ware, change this setting to “Saved Position ”

• Hoop Calibration: After a firmware update, 

it is recommended to calibrate the hoops 

• Cut and Secure: Here you can turn on Quilt 

Settings (which can also be changed in the 

Stitchout Summary, to be covered later)  You 

can also set “Thread cut after start” which 

tells the machine to stitch a few stitches and 

then stop, allowing you to trim the thread 

tails  This can be helpful when quilting in the 

hoop, as the bobbin thread should be pulled 

to the top for the initial stitching 

• Unit of Measurement: You can choose 

inches or millimeters  For the activities in this 

workbook, choose millimeters 

• SPI (Customizable Quilt Designs): Allows 

you to set the stitches per inch for your 

customizable quilt designs 

FILE FORMATS

The B 990 is one of many BERNINA embroidery 

machines that reads multiple formats  The native 

format for BERNINA machines is the BERNINA EXP 

extension which, when exported from BERNINA 

Embroidery Software, often includes two addi-

tional supporting files: a BMP file that provides a 

preview of the embroidery motif, and an INF file 

with the color information  If the INF file is missing, 

the embroidery may not be displayed in the actual 

color, but only in standard colors  In that case, 

simply follow the thread chart that is provided with 

most designs, or enter the colors manually in the 

color overview of the motif on the machine  See 

your machine’s manual for more information 

Chapter II 

Fig. 3 
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Besides the BERNINA embroidery file format, 

your machine can also read: PES, PEC, XXX, PCS, 

JEF, and DST 

In addition to embroidery formats, your B 990 

can also read customizable quilt designs (longarm 

formats): BQM, HQF, PAT, PLI, QLI, and TAP 

FEATURE FOCUS

File Manager

In the File Manager, you can load and manage 

embroidery designs  You can access it by tapping 

the Add Design (+) icon in the Layer Bar  There 

are multiple folders on the main screen to help 

you navigate to the type of motif you would like 

to work with  Note that to the right of the File 

Manager is the Quick Access Bar, which offers 

shortcut icons that correspond to the different File 

Manager options: 

• Embroidery designs

• Lettering

• Sewing stitches 

• Personal Folder

• USB (when applicable)

The File Manager enables you to access any design 

within the machine, such as the on board embroi-

dery designs, customizable alphabets, and sewing 

stitches, all of which can be embroidered  Here 

you can also access the Personal Folder (to save 

and manage your own designs) and the USB stick, 

which will appear as a blue USB icon when a stick 

is inserted into the machine  You can even create 

folders within your USB stick and Personal Folder 

to aid in the organization of your embroidery files  

In the Toolbar at the top of the screen you have 

options to rename, cut, copy, paste, select all, or 

delete files and/or folders  You can also search for 

designs, create new folders or gather folder or file 

information from the Toolbar  

DESIGN SELECTION

There are two ways to select a pre-installed design 

from the File Manager 

Folder Navigation

1   From the Layer Bar, select the Add  

 Design (+) icon to open the   

 File Manager 

2  Select the Embroidery Designs folder 

3  Select the Lace folder  Notice the path in the 

Navigation Bar that shows the folder layers 

you are in (Fig  4)  

4  Tap the Back button twice to return to the 

main File Manager screen  

Fig. 4   
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Search Function

With the Search function, you can locate a design 

by name or number within a folder 

1  Select the Embroidery Designs folder 

2  Select the Flowers folder 

3   Select the Search icon at the top 

left of the File Manager screen  A 

full- screen search window will appear 

4  Enter the design number, 51322-08, using 

the number pad  As the numbers are input, 

the search preview narrows down all designs 

that include the input number  Eventually, 

the search will narrow down to the exact 

number (Fig  5) 

5  You will see a preview of the design; select it 

with a one-finger touch  Once selected, the 

design is added to the Design Altering Area 

and Layer Bar (Fig  6) 

Stitch Information

In the upper left corner of the 

screen you will see stitch infor-

mation, including the total time 

to stitch the design, the size, 

and the number of colors  

You can also see this information at a glance before 

choosing a design by long pressing on the design  

A pop-up window (Fig  7) will appear with the 

following information for you to review:

• A full-color picture of the design

• The design name and file type

• Total stitch time

• Stitch count

• Thread colors

• Recommended hoop

• Design size

Fig. 7   

Fig. 5   

Fig. 6   
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BASIC EDITING

In this section, explore embroidery design 

editing  Begin with design 51322-08 on 

screen (from the previous chapter) 

BOUNDING BOX

Each design or selection has a 

blue rectangle around it called 

the Bounding Box  Using touch 

gestures, the nodes (white dots) 

enable  you to res ize  and/or 

re-shape your design on the screen  

They are located at each corner and 

at the center of each side 

By selecting one of the corner nodes and dragging, 

you will resize the design proportionally  By resizing 

with one of the center side nodes, you will modify 

the design disproportionally  To rotate the design, 

use the circle with the curved arrow to move the 

design along a central radius     

EDIT SUBMENU

The Edit Submenu (Fig  8) appears when you open 

the Edit Menu and you can select the options for 

how you wish to edit the design  Many of these 

functions can also be performed with touch gestures 

on the screen 

Move

When the Move icon is selected in the 

Editing submenu, the dialog will open 

and display the current X and Y axis 

position values and you have a variety of 

ways to move your design around 

• Move the embroidery motif with your finger 

directly on the screen 

• Move the embroidery motif horizontally with 

the upper Multi-function Knob, and vertically 

with the lower one 

• Move the embroidery motif with the plus (+) 

and minus (-) icons 

Chapter III 

Fig. 8   

Tip:

When more than one design is selected, the 

Bounding Box is reshaped to fit the entire 

selected area of all the selected designs  Resize 

modifications are then made on all selected 

designs in the Bounding Box  When multiple 

selections or Select All is chosen, only propor-

tional sizing is allowed 
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EDIT SUBMENU

The Edit Submenu (Fig  8) appears when you open 

the Edit Menu and you can select the options for 

how you wish to edit the design  Many of these 

functions can also be performed with touch gestures 

on the screen 

Move

When the Move icon is selected in the 

Editing submenu, the dialog will open 

and display the current X and Y axis 

position values and you have a variety of 

ways to move your design around 

• Move the embroidery motif with your finger 

directly on the screen 

• Move the embroidery motif horizontally with 

the upper Multi-function Knob, and vertically 

with the lower one 

• Move the embroidery motif with the plus (+) 

and minus (-) icons 

•  Center the embroidery motif   

  by tapping the Center Motif icon  

• Reset the embroidery motif by tapping the 

yellow boxes (they will reset to blue) 

Rotate

The design can be rotated in 1-degree 

increments with the plus (+) and minus 

(-) buttons in the dialog box  You can 

also rotate by 45 degrees clockwise and 

counterclockwise 

• Rotate the embroidery motif in the Design 

Altering Area using the rotation arrow icon 

on the Bounding Box 

• Rotate the embroidery motif with the 

Multi-function Knobs 

• Rotate the embroidery motif with the plus (+) 

and minus - icons 

• Rotate the embroidery motif with the slider 

(Fig  9)  

•  Rotate the Embroidery motif in  

 45-degree increments, clockwise 

and counterclockwise 

• Reset the embroidery motif to 0-degree rota-

tion by tapping the yellow box 

Resize

In addition to resizing the design with 

the Bounding Box nodes, you can also 

change the embroidery motif size with 

the Resize icon 

Resize Proportionally

In the Resize dialog box, the Proportional 

icon is on by default; it is the chain-

looking icon in the blue box  This locks 

the height and width to maintain propor-

tion when resizing  Resizing proportionally also 

works with Multiple Selection; designs are modified 

at the same percentage together 

• Resize the embroidery motif proportionally by 

dragging the corners of the Bounding Box 

• Resize the embroidery motif proportionally 

using the plus (+) and minus (-) icons 

• Resize the embroidery motif proportionally 

using the Multi-function Knobs 

• Reset the embroidery motif to size default by 

tapping the yellow boxes 

Resize Disproportionally

In the Resize dialog box, deselect the 

Proportional icon (the chain-looking 

button) to unlock  It will now look like a 

broken chain 

Fig. 9 
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• Resize the embroidery motif disproportionally 

by dragging any of the center side nodes of 

the Bounding Box 

• Resize the embroidery motif disproportionally 

using the plus (+) and minus (-) icons 

• Resize the embroidery motif disproportionally 

using the Multi-function Knobs 

• Reset the embroidery motif to size default by 

tapping the yellow boxes 

Duplicate

When selected, the current selected 

design will be duplicated  The duplicated 

layer is always added to the top layer 

This function also works with Multiple Selection  

When multiple or all designs are selected, a layer 

is added to the top, which you can see in the layer 

bar to the right 

Tap Duplicate to copy the design  Note the new layer 

Mirror

The Mirror Left/Right and Up/

Down icons flip the selected 

layers on the vertical or hori-

zontal axis  When a design has 

been modified, the icon will have a yellow bar  Tap 

it to reset 

These functions also apply to Multiple Selection 

• Mirror the duplicated layer using the Mirror 

Left/Right icon  Note: when the function has 

been selected, it has a yellow highlight 

• Select the original motif layer and mirror it 

with the Mirror Up/Down icon (Fig  10)  

•  Tap the Undo button to reset the  

 mirror image of the original design  

Delete 

You can delete selected motif(s) by 

selecting the Delete icon  A confirma-

tion window pops up to confirm  The 

green checkmark will delete the item(s), 

the “x” will close the window  This function works 

in Multiple Selection and Select All modes 

Fig. 10   
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Stitch Density

With this icon, you can adjust the 

stitch density of embroidery designs  

Values range from 25 to 300%; the 

default is 100% 

• Adjust using the plus (+) and minus 

(-) buttons 

• Use with the bottom Multi-function Knob to 

adjust by percentage  Change to 60% 

• Tap the green checkmark to confirm  The 

image will then change in the Design Altering 

Area to reflect the change 

• Tap the Undo button to return to the original 

stitch density 

Colors

Thread colors can be easily modified in 

embroidery designs by using the Colors 

icon  The thread colors are shown in  

the order they will be stitched for the 

selected layer(s) 

The following are displayed in the Color Overview 

Menu (Fig  11) when you tap the Color icon:

• Color

• Thread color order

• Icon representing the type of embroidery 

being done (thread, cut, paintwork, crystal)

• Thread color number

• Thread brand

• Change Thread Color icon

Change Thread Color Icon

By selecting the Change Thread Color 

icon, you can change the thread colors 

individually  

This will open a new menu (Fig  12), allowing you to 

modify the current thread color and/or brand  

The overview shows all the threads as colored circles 

with the manufacturer’s thread number  The current 

color is always the first color in the first row; it has a 

blue circle around it and a checkmark in the center 

•  Search for a color number in the  

 current thread brand by selecting  

 the search icon  When selected,  

 the window opens with the 

number pad and an array of available color 

numbers from the brand  

• Enter a thread color number, then tap 

the checkmark to select that thread color  

Selecting the “x” at the bottom of the screen 

will exit the Search Menu  

• You can also scroll through the other colors 

in the embroidery motif(s) using the up/down 

Fig. 12   

Fig. 11   
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arrows on the Color Number Bar, just above 

the Palette icon above the colors 

• Select a new color from the color options, 

scrolling with your finger  The color will 

change on the Design Altering Area (Fig  13) 

•   Tap the small Palette icon to   

 change the thread brand for that  

 individual color 

• Select a brand and then tap the desired color 

(Fig  14) 

Modified colors are shown with a yellow bar to the 

left of the thread color information (Fig  15) 

Back to Default

Select the Back to Default Icon to reset the 

colors to their original threads         

Change Brand

On the main Colors menu, you will see 

the Change Brand Icon  This allows you 

to change the thread brand for all colors  

Tapping it opens the Palette menu, where 

you can select a new brand  All the thread colors 

in the design will be reassigned to hues in the new 

manufacturer, based on the closest color value (RGB) 

Color Wheel

By selecting the Color Wheel icon, you 

have more ways to edit and change the 

colors within the design  

• Select the color you wish to change, and 

notice its corresponding node highlighted on 

the Color Wheel   

 

 

 

Fig. 13   

Fig. 14   

Fig. 15   
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• Use your finger to move the node to a new 

color area on the wheel; see how it changes 

in the embroidery motif (Fig  16)  If needed, 

open Edit » Colors » Color Wheel again 

• Use the Left/Right slider at the top of the 

Color Wheel to change the overall hue of the 

design  All colors will be adjusted 

• Use the Brightness slider below the Color 

Wheel to adjust the value of your selected 

color (Fig  17)  

The color preview will auto populate with the closest 

thread color that manufacturer has 

Once colors are adjusted, the new values are 

updated in the Color Overview Menu  

Shape Designer

The Shape Designer feature allows you 

to arrange embroidery motifs around a 

designated shape and with options such 

as count, width, height, mirror, and justify  

You can create some truly unique design combinations 

Delete any designs  

Add Design » Embroidery Design » Mini

1  Select design #OC86074 

2  Select the Oval Hoop 

3  Select Shape Designer from the Edit Submenu 

4  Select the hexagon shape 

5  Under Item Count, use the plus (+) and minus 

(-) buttons to change the number of motifs 

to 6 (values range from 1 to 100 and can be 

reset by tapping the adjusted value box) 

Fig. 16   

Fig. 17   
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6  Ensure the Proportional icon is selected (the 

chain link) and in either the Shape Width or 

Height boxes, adjust the shape to 22% 

7  Close out of the Edit Menu and admire the 

look (Fig  18) 

8  Reopen the Edit Menu and Shape 

Designer function 

9  Change the Item Count to 12 

10  Change the width and height to 67% 

11  Tap the Inside icon under Justification  Note: 

When Inside is selected, the designs are placed 

inside the shape and the top of the Bounding 

Box aligns with the shape baseline  When 

Outside is selected, the designs are moved 

to outside the shape and the bottom of the 

Bounding Box aligns with the shape baseline 

12  In the Rotate box, rotate the design by 45% 

four times (Fig  19) 

ARRANGE SUBMENU

The second submenu in the Edit Menu is Arrange 

(Fig  20)  Its functions include: Group, Ungroup, 

Move Forward, Move Backward, and Align, and 

Match Start/Stop 

Group and Ungroup

The Group icon groups selected 

layers together and sets it in 

the bottommost layer  You can 

select multiple layers to group  

You can ungroup layers, motifs, and even thread 

elements in a design  The layers are then displayed 

individually in the Layer Bar and can be edited 

separately with functions such as delete, move, 

rotate, etc 

Move Up and Move Down

The Move Up icon moves a motif 

or layer up one layer at a time in 

the Layer Bar  The topmost layer, 

indicated by the highest number, 

is stitched last 

Fig. 18   Fig. 19   

Fig. 20   
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Likewise, the Move Down icon enables you to move 

a selected layer downward in the Layer Bar, one layer 

at a time  The bottommost layer, labeled as layer 1, 

is stitched first, followed by layers 2, 3, 4, etc 

Designs or motifs can also be rearranged in the Layer 

Bar by dragging and dropping into position  Tap and 

hold on the layer you wish to move  When the layer  

is highlighted in white in the Layer Bar, you can then 

drag it into the desired order 

Align

You can select multiple designs or layers 

and align them perfectly with the Align 

function  You must have multiple layers to 

see this option in the Arrange submenu  

Justification options (Fig  21) include:

• Align Left: Designs are aligned to the left-

most boundary of selected items 

• Align Vertical Center: Designs are aligned to 

the vertical center of the boundary boxes 

• Align Left: Designs are aligned to the left-

most boundary of selected items 

• Align Top: Designs are aligned to the 

topmost boundary of selected items 

• Align Horizontal Center: Designs are 

aligned to the horizontal center of the 

boundary boxes 

• Align Bottom: Designs are aligned to the 

bottommost boundary of selected items 

You will experiment with the Arrange submenu in a 

future exercise 

Match Start/Stop

With Match Start/Stop, you can precisely 

align two designs end to end, like 

customizable quilt designs or sewing 

stitches  This will move the start point of 

a motif to the end point of the previous design  

Use this feature in combination with the Reduce 

Thread Changes function in the Stitchout Summary 

to ensure designs stitch continuously without stops 

FEATURE FOCUS

Contextual Icons

Icons on the B 990 are contextual  This means they 

will only be available when you are able to use them  

For example, if you only have one object on the 

screen, icons that do not apply, such as “Group,” 

will be grayed out 

Fig. 21   
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BASIC EDITING

Materials & Machine Settings

(1) 10” x 15” piece of fabric and (1) 10” x 15” 

piece of stabilizer

Needle: Jersey Needle 80/12 130/705 H-SUK

Hoop: Oval Hoop

Foot: Embroidery Foot #26L 

Hoop your fabric and attach to the module following the 

intructions on page 3  Delete any designs currently 

on your screen before beginning  

Add Design » Embroidery Designs » Borders

1  Select design #12445-18 

2  Select the Oval Hoop 

3  Using the Rotate icon just above the design, 

rotate the design 90 degrees (Fig  22) 

4   Select the Edit Menu 

5   Select Duplicate 

6   Tap Mirror Up/Down once (Fig  23) 

7  In Selection Options, choose Select All 

8  Tap Duplicate once 

9  In Selection Options, Choose Single Select 

10  Move the flower borders so they alternate up 

and down and do not overlap (Fig  24) 

11  In Selection Options, Choose Select All 

12   Choose Align from the Arrange Submenu 

Exercise 1

Fig. 22   

Fig. 23   
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13  Select Center Vertical 

14  Select Distribute Horizontal 

15  Return to the Edit Menu with the Back Arrow 

at the top of the Arrange Menu 

16  Select Move from the Edit Menu 

17   Touch the Center Icon to   

 return the design to the center  

 of the hoop 

18  Return to the Edit Menu      

Select Colors 

19   Using the Change Thread Color  

 icon, alternate the design colors  

 with Isacord 0015 and 1902   

 (Fig  25) 

20   Select Stitchout  

 

21  In the Stitchout Summary (Fig  26), select: 

 o Presser Foot: #26

 o Thread Away: On

 o Color: Reduce Thread Changes

22  Select Confirm 

23  Stitch the Design in hoop 

24  Tap Finish Embroidering when the stitching 

is complete 

Fig. 24 

Fig. 25    

Fig. 26    
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LETTERING

The BERNINA 990 features advanced lettering in 

embroidery  Lettering can be created on its own 

or added to other designs, and can be set to any 

desired size with full stitch recalculation 

ADD LETTERING

Delete any designs on the screen 

Add Design » Alphabet Folder

1  Choose the Art Deco Block lettering  A 

keyboard will appear where you can type your 

message  The keyboard looks like the one you 

might find on your computer or smart phone 

and works similarly 

2  Type in the word “Magic” (Fig  27) 

Text is shown in the selected font  New font 

styles can be selected in the font overview above 

the keyboard 

Keyboard Shortcuts

Upper and Lower Case

The default for text is to capitalize the 

first letter and then use lowercase letters  

You can choose upper or lowercase 

letters by toggling off or on the Cap Lock 

icon  You can also double-tap the Cap Lock icon 

for all caps 

Special Characters

Access special characters, like “È,” by 

long pressing on the keyboard character 

or by using the Special Character icon at 

the bottom left of the keyboard 

Numbers

Numbers can be accessed with the 

Number icon at the bottom left   

Multi-line lettering and Justification

To enter more than one line of text, use 

the Enter icon 

If your text has more than one line, you 

can align your text with the three justification icons 

at the top left of the keyboard: align left, align 

center, and align right  You will use this function in 

a later exercise 

3  Touch the green checkmark to confirm and 

place your “Magic” lettering on the screen  

4  Select the oval hoop  

 

Fig. 27   

Chapter IV



Copyright © 2024 BERNINA of America. Please do not reproduce.  |  bernina.com
19

EDITING LETTERING

Lettering editing options are in the Lettering 

submenu of the Edit Menu (keep in mind the menu 

is not visible if lettering has not been selected)  

These enable you to customize and refine the look 

of your text 

Edit Text

Edit or modify your text with the Edit 

Text icon  Confirm your changes with the 

green checkmark; cancel your changes 

with the gray “x”  You can also edit text 

with the Context Menu (tap and hold in the Design 

Altering Area) 

Transform

In the Transform menu, 

you can change the 

shape of the lettering  

Choose from: Hori-

zontal (default), Vertical, or Arched 

• Select Vertical  Your lettering transforms to 

vertical text (Fig  28) 

• Tap Undo once to revert to the original 

arrangement  

• Select Arch  Here you can adjust the curve 

of the baseline up or down using the plus 

(+) or minus (-) icons or the top and bottom 

Multi-function Knobs (Fig  29)  Note that 

Vertical and Arch options cannot be used 

with multi-line lettering  Experiment with 

these settings 

• Touch the yellow box to reset the arch to 0 

• Return to the Lettering menu using the back 

arrow key twice 

Fig. 28   

Fig. 29   
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Spacing

The space, or kerning, between letters 

can be adjusted with the Spacing func-

tion  The top and bottom Multi-function 

Knobs or the plus (+) and minus (-) can 

adjust the spacing from -500 to 500 

• Increase the spacing to widen the space 

between letters (Fig  30)  

• Tap the minus (-) button to a negative number 

to reduce spacing between letters  

• Touch the yellow box to reset the 

spacing to 0 

Line Spacing

The distance between the lines can be 

adjusted with the Line Spacing function  

Line spacing is only active with multi-

line text  

Just l ike with Spacing, the top and bottom 

Multi-function Knobs or the plus (+) and minus (-) 

can adjust the spacing from -500 to 500  

Styling

Multiple adjustments can be made to 

lettering in the Style menu: Stitch Density, 

Pull Compensation, and Satin Value 

• Stitch Density: Stitch Density adjusts the 

density of stitching in the letters and can be 

modified with the Multi-function Knobs or 

the plus (+) and minus (-)  Values range from 

25% to 300% 

• Pull Compensation: Pull Compensation 

adjusts for the fabric being pulled in when 

the lettering is stitched  The amount of pull 

can be adjusted with the plus (+) and minus 

(-) buttons, at values from -1 0 mm to 2 0 

mm, depending on the fabric type and pull of 

the lettering 

• Satin Value: The Satin Value will change 

a satin stitch fill to a step stitch  The size in 

mm shown will adjust anything over that 

length to become a step fill stitch  Value can 

be adjusted with the plus (+) and minus (-) 

buttons in a range of 0 5 mm to 15 mm 
Fig. 30   
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SHAPE DESIGNER AND LETTERING

Materials & Machine Settings

(1) 10” x 15” piece of fabric and (1) 10” x 15” 

piece of stabilizer

Needle: Jersey Needle 80/12 130/705 H-SUK

Hoop: Oval Hoop

Foot: Embroidery Foot #26L

Hoop your fabric and attach to the module following the 

intructions on page 3  Delete any designs currently 

on your screen before beginning  

Add Design » Embroidery Designs » Mini 

1  Select design #OC86074 

2  Tap Add Design again and select 

design #OC86069 

3  Select the Oval Hoop if not already selected 

(Fig  31) 

4  In Selection Options, choose Select All 

5  Tap the Edit Menu and select Shape Designer 

6  Choose the Circle Shape (Fig  32)  

7  Set Item Count to 8 and Justification to Inside 

(Fig  32) 

8  Select Add Design  

9  Choose Lettering and select Art Deco Block  

10   Type “Create” (enter) “Your” 

(enter) “Magic” 

Exercise 2 

Fig. 31    

Fig. 32    
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11  Preview different fonts by selecting them 

above the keyboard  Select Atlantic Script 

and Confirm 

12   Tap the Edit Menu and select Edit Text 

13  Select Center Justification and choose 

Confirm (Fig  33) 

14  Using the on-screen handles, reduce the 

design to fit within the circle  Move the 

lettering to place it as desired (Fig  34) 

15  Tap and hold the lettering layer in the Layer 

Bar and drag it below the wreath design 

(Fig  35)  This will make the lettering sew 

before the wreath 

16   Select Stitchout 

17  In the Stitchout Summary, select: 

 o Presser Foot: #26

 o Thread Away: On

 o Color: Reduce Thread Changes

18  Select Confirm 

19  Stitch the Design in hoop 

20  Tap Finish Embroidering when the stitching 

is complete 

Fig. 33   

Fig. 34   

Fig. 35   
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PLACEMENT

Discover how to perfectly place your embroidery 

design in this chapter with the Position Submenu 

POSITION SUBMENU

The following functions are under the Position 

Submenu (Fig  36): Design Center, Check Design, 

Virtual Positioning, Pinpoint Placement, Endless 

Embroidery, Match Start/Stop, and Flip Start/Stop 

Design Center

The needle moves to the center position of the 

selected layer(s)  The hoop must be on the machine 

to activate 

Check Design

Verifies the position of the embroidery 

motif before stitchout by moving the 

hoop so that the needle is centered over 

each location tapped  A hoop must be 

attached to use this function; if the icon is selected 

and no hoop is attached, a prompt will appear to 

attach the hoop  

You can also use the plus (+) or minus (-) icons, or 

Multi-function Knobs, to move the embroidery 

design horizontally or vertically (Fig  37)  The hoop 

will move in conjunction with the design movement 

Virtual Positioning

The B 990 moves the attached hoop to 

the position of your selected point in 

the design on the screen, or where the 

selected crosshair symbols is  As long as 

this icon is active (highlighted yellow) and the hoop 

is attached, the position within the hoop on screen 

can be tracked  This allows you to precisely place to 

a single stitch if desired 

Pinpoint Placement

Allows embroidery motifs to be placed 

within the hoop in a specific position  

You will explore this tool in Exercise 3 

on page 25 

Endless Embroidery

The Endless Embroidery function allows 

for easy alignment of embroidered 

borders that are longer than the hoop  

The design is multiplied to fill the hoop, 

Chapter V 

Fig. 36   

Fig. 37   
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and marker positions are inserted to help with the 

re-positioning of the embroidery hoop (Fig  38) 

• Reference Marker: Set or modify marker 

points by selecting the arrow buttons; the 

blue arrow icon corresponds to the red arrow 

marker point shown in the Design Altering 

Area  Arrows are generated as they are 

selected and are all grouped together on a 

single separate layer 

• Number of Embroidery Designs: Select the 

number of desired motif repeats using the top 

Multi-function Knob or the plus (+) and minus 

(-) buttons in the dialog  Repeats are added 

without spacing as default 

• Fit to Hoop: When Fit to Hoop is toggled on, 

the designs will resize to fit the selected hoop 

automatically 

• Spacing: Adjust the spacing between design 

repeats by using the bottom Multi-function 

Knob or the plus (+) and minus (-) buttons  

Value is changed 0 1 mm increments, ranging 

from -300 mm to 300 mm  You will see the 

modifications in the Design Altering Area 

After making all the selections, you will confirm your 

settings and continue with your stitchout 

To repeat and continue your Endless Embroidery 

design, rehoop the fabric so that the stitched-out 

marker positions are within the stitching field of 

the hoop  Use Pinpoint Placement with Free Point 

Selection to align your next hooping, selecting and 

matching the points of the marker positions  Read 

more about Pinpoint Placement later in this book 

Show Start/Stop

Displays the first and last stitch of each individual 

embroidery design in the Design Altering Area  

Green indicates the first stitch, and red is placed at 

the last stitch 

Flip Start/Stop

Reverses the stitch path of customizable quilt 

designs   

Fig. 38   
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PLACEMENT

Materials & Machine Settings

(1) 10” x 15” piece of fabric and (1) 10” x 15” 

piece of stabilizer

Needle: Jersey Needle 80/12 130/705 H-SUK

Hoop: Oval Hoop

Foot: Embroidery Foot #26L

PREPARE HOOPED FABRIC

• On a 10” by 15” piece of dark fabric, use a 

straightedge ruler to draw two non-parallel 

chalk lines at opposite angles approximately 4” 

down from the top of the fabric for the first 

line and another 3-4” below that one for the 

second line  

• Using the hoop template as a reference, draw 

a diamond shape that will fit within your oval 

hoop, below the two reference lines (Fig  39)  

ATTACH HOOP & SCAN FABRIC

Hoop your fabric following the intructions on page 

3  Delete any designs currently on your screen 

before beginning 

1   Select the View icon  

 

2   Select the Hoop Background icon  

 

Exercise 3 

Fig. 39   
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3  Select Scanned Image from the dropdown, 

then Scan Hoop (Fig  40) 

4  Attach the hoop when prompted to do so 

(Fig  41)  You will receive a message to make 

sure the area is clear for the hoop to move  

Select the green check to confirm 

5  The hoop will now be scanned (Fig  42) 

6  When the machine finishes scanning, select 

the green check mark to confirm the scanned 

image and close the Hoop Background menu 

FEATURE FOCUS

Pinpoint Placement and Pinpoint Laser

With Pinpoint Placement (in the Position Submenu), 

positioning points allow for the precision placement 

of a design while rotating and resizing the design to 

embroider correctly, even if the hooping is crooked  

It is highly recommended to use the Pinpoint Laser 

when using any Pinpoint Placement mode  It makes 

it easy to precisely center your needle over the 

correct placement on the fabric 

DESIGN PLACEMENT

Add Design » Embroidery Designs » Borders

7  Select design #FB038 (Fig  43) 

8   Turn on the Pinpoint Laser   

 

9   Select the Edit Menu, then choose Pinpoint 

Placement in the Position submenu  

10   Select Retain Size   

 This will keep the size  

 of the design locked, 

Fig. 40   

Fig. 41   

Fig. 42   
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allowing only for reposition-able movement 

of the design  When it is off, the design can 

be rotated, moved, and resized  

There are three modes for placement: Grid, Free 

Point, and Four Point  We’ll use each of these in the 

following steps  

Grid Placement

Grid (default positioning) allows for 

the positioning of an embroidery motif 

based on the nine points of the motif’s 

Bounding Box  When you select a point 

in the 9-point grid, the hoop will move to match this 

reference point in the design  Only two points can 

be positioned in Grid mode 

11  Select Grid 

12  Tap the reference point on the middle left 

of the grid on the design in the Design 

Altering Area 

13  Use the Multi-function Knobs to move this 

point onto the left side of the top line marked 

on your fabric  Zoom in if needed and use the 

Pinpoint Laser to confirm placement (Fig  44)  

14  When the point is aligned, select the green 

thumbtack icon to pin this point 

15  Now select the middle reference point on 

the far right side of the grid on the Design 

Altering Area 

16  Use either Multi-function Knob to rotate the 

design until satisfied with its placement on 

the line (Fig  45) 

17  Select the green thumbtack to confirm the 

placement  

18  Return to the Edit Menu using the back arrow 

Fig. 44   

Fig. 45   

Fig. 43   
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Free Point

Free Point placement allows the posi-

tioning of a design based on any two 

stitches in the embroidery motif  The 

Zoom slider, as well as the zoom touch 

gestures, can zoom in on a specific stitch within the 

design  When you select a stitch, the hoop will move 

to match where this reference point lies on the fabric  

Only two points can be positioned in Free Point mode 

Add Design » Lettering » Atlantic Script

19  Type “Happy”, then confirm with the 

green check 

20  Go to the Edit Menu 

21   Select the Edit Menu, then choose Pinpoint 

Placement in the Position submenu 

22  Select Free Point 

23  Select the bottom left corner of the letter H 

24  Use the Multi-function Knobs to move this 

point onto the second drawn line and select 

the green thumbtack to set in place (Fig  46) 

25  Select the bottom of the upper portion of the 

letter “y” (the portion that would rest on the line if writing on lined paper) 

26  Use the Multi-function Knobs to align this portion of letter on top of the line, too  Now “Happy” 

looks like it was written on lined paper with the “y” going below the chosen baseline (Fig  47) 

27  Select the green thumbtack to set the design  The placement points will disappear once the second 

point is set 

28  Close the Edit Menu 

Fig. 46   

Fig. 47   
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Four Point

Four Point placement allows the embroi-

dery motif to be positioned within the 

hoop based on four points  You will have 

two different options when using Four 

Point: Fit and Morph (Fig  48) 

When morph is selected, the embroidery motif can 

be transformed to fit within the desired design 

shape  Note that this may distort or change the 

look of the design and thus performs best with line-

work designs like quilting designs  When you select 

a point, the hoop will move to match where this 

reference point lies on the fabric 

Add Design » Embroidery Designs »  
Inspirations » Quilt

29  Select design #Q102  Zoom out to see 

the design 

30  Select the Edit Menu 

31  Resize the design to fit in the hoop 

32  Select Pinpoint Placement, Four Point, 

then Morph 

33  Select one corner of the design 

34  Use the Multi-function Knobs to align that 

point to match a position marked on the 

hooped fabric (Fig  49) 

35  Repeat with all four points of the design 

(Fig  50) 

36  Set an inner margin of 6 mm (Fig  51)  The 

design is now set within the shape, with an 

equidistant margin from the sides 

37  Close the Edit Menu 

Fig. 49   

Fig. 50   

Fig. 51   

Fig. 48   
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38   Select Stitchout 

39  In the Stitchout Summary, select: 

 o Presser Foot: #26

 o Color: Single Color

40  Select Confirm 

41  Stitch the Design in hoop in all white 

42  Tap Finish Embroidering when the stitching is complete 

FEATURE FOCUS

Fit

When Fit is selected, a design can be made to fit within the boundaries of the desired design shape, without 

distorting the design within the shape  When you select a point, the hoop will move to match where this 

reference point lies on the fabric 



Copyright © 2024 BERNINA of America. Please do not reproduce.  |  bernina.com
31

SAVING DESIGNS

The Save icon appears as soon as you have added 

a design  This section goes over how to save your 

customized designs for future use 

SAVE TO PERSONAL FOLDER

You can save any design, including all the custom-

ized stitch settings you created, by saving it to the 

machine in the Personal Folder 

Delete any designs on the screen 

 Add Design » Lettering » Art Deco

1  Type “BERNINA 990” with a line break 

between “BERNINA” and “990” 

2  Select Center Justification 

3  Confirm with the green checkmark 

4  Select the Oval hoop is needed 

5  Tap Add Design, then from the Embroidery 

Designs folder, select the Hobbies folder 

6  Select design #12796-07M 

7  Rotate the heart 90 degrees using the 

Rotate handle 

8  Use your finger on the Design Altering 

Area to move the heart above the word 

“BERNINA” 

9  Resize and move as needed 

10  Select both layers 

11  Select the Edit Menu 

12  Tap Align from the Arrange submenu, then 

choose Center Horizontal (Fig  52) 

13   Select the Save icon at the bottom 

of the screen  

14  Type “B 990” for the file name 

15  Confirm with the green checkmark 

16  Confirm again to save the design in the 

Personal Folder (Fig  53) 

 
 

Chapter VI 

Fig. 52   

Fig. 53   



Copyright © 2024 BERNINA of America. Please do not reproduce.  |  bernina.com
32

RETRIEVE FROM PERSONAL FOLDER

1  Delete your design from the screen 

2  Select Add Design (+) icon in the Layer Bar 

3   Select the Personal Folder  

 

4  Select the saved “B 990” design to place it on 

the screen (Fig  54) 

SAVE/OPEN FROM USB

You can save a design to a USB stick to use 

in software or free up space in your B 990  

1  Select the Save icon at the bottom of the 

screen again 

2  Name the motif as desired using the 

keyboard  

3  Confirm name with the green checkmark 

4  Select the USB icon at the top of the screen 

5  Confirm save with the green checkmark 

To retrieve your motif from a USB, select the Quick 

Access Bar to the right of the File Manager, then the 

USB icon, to find your motif 

Fig. 54   
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STITCHOUT SUMMARY

You have seen the Stitchout Summary while working 

through the exercises in this workbook  Let’s go over 

it in a little more detail now  

STITCHOUT SUMMARY

When it is time to stitch out your embroi-

dery motif, select the green Stitchout 

needle icon at the bottom right of 

the screen 

The Embroidery Stitchout Screen (Fig  55) allows for 

final adjustments of common embroidery settings  

You can change these options with every stitchout  

Modifications are kept until they are changed or 

factory settings are restored 

• The Hoop status shows the detected hoop  

If a hoop is not attached, it is highlighted in 

red  A hoop does not need to be attached to 

the machine to enter this screen  

• The Stitch Plate status shows the detected 

plate  If a plate is not attached, it will be 

highlighted in red    

 

• You can select a 

different foot from 

the Presser Foot drop-

down menu (Fig  56) 

or select it from the 

Presser Foot recog-

nition screen on 

the Status Bar  Only 

compatible embroi-

dery feet are shown in 

the dropdown menu  

If a presser foot is 

not selected, the machine will prompt you to 

attach one 

• Quilt Settings adjust several cut and secure 

settings at once  It is suggested for all 

customizable quilt designs, such as BQM  

Selecting it requires you to pull the thread 

up at the beginning and end of a stitchout 

the with Needle Up/Down button  The 

default is off 

• The Thread Away function causes a swift 

movement of the hoop after a thread has 

been cut that pulls the top thread up out of 

the fabric and brings it out of the way so the 

top side of the embroidery project will be 

perfectly clean with no thread to clip  Thread 

Away mode can be turned off or on when the 

Quilt Settings are turned off  Thread Away 

Mode is turned on by default 

Chapter VII 

Fig. 55    

Fig. 56    
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• The Color dropdown menu has multiple 

options for how colors are handled during 

embroidery 

 o Multi Color: Causes the motif to stitch 

out as is  After each color, the machine 

stops so you can change the threads 

 o Single Color: Embroiders the design 

with the color currently threaded 

without interruptions, even if many 

colors are used 

 o Reduce Thread Changes: Combines like 

colors together, resulting in less thread 

changes  Use caution when selecting 

this for layered embroidery designs, 

as it will affect the stitching order of 

the design 

• Basting allows for the addition of a basting 

box around the design or hoop 

 o Off: This is the default option and will 

not stitch out a basting box 

 o Around Design: A basting box will 

be added around the outside of the 

embroidery motif(s) being stitched  

When Around Design is selected, you 

will also be presented with the option 

to choose how far the basting box 

stitches from the edge of the design 

 o Around Hoop: A basting box will be 

added around the whole outside of the 

embroidery hoop 

• Thread Cutting allows you to cut with every 

color change, cut by jump stitch length, 

(defined by millimeter), or never  Default is set 

to Jump Stitch, 6 mm length 

 o Off: Threads are never cut 

 o On Color Change: Jump stitches are 

only cut when the machine transitions 

from one color to another 

 o On Jump stitch: Cuts all jump 

stitches in the design, determined 

by connecting stitch length from 1 

mm to 15 mm 

• Fabric Thickness offers better automatic 

tension  You can set the value to 4 mm 

(default), 7 5 mm, or 10 mm 

Once satisfied with the settings, tap the green 

checkmark to confirm the selections and continue 

to the Embroidery Stitchout Screen  Tap the gray  “x” 

icon to return to the Edit screen 

STITCHOUT SCREEN

The Embroidery Stitchout Screen appears when 

the design is ready for Stitchout (Fig  57)  Once 

here, you can begin to stitch by pressing the Start/

Stop button 

Fig. 57   
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Design Preview

The Design Preview displays the 

design as it will be stitched out  

Only the current color layer is 

shown, with the other color 

layers grayed out  Use the View 

icon to modify the viewing size 

in the Design Preview Area 

Color Bar

The color bar beneath the Design Preview offers a lot 

of helpful information about the stitchout 

All colors in the stitchout are shown in relation to 

the number of total stitches in the design  The more 

stitches, the longer the bar  Use the arrows or swipe 

to scroll through the bar and view additional colors 

in the design  When a color is selected, the hoop is 

moved to the starting position for that color, and the 

color shows in the Current Color Bar 

Current Color Bar

Below the Color Bar is the Current Color Bar, 

showing the current color to be stitched  The slider 

progresses as the color is stitched out and can be 

moved to jump to a different position in the color 

layer when the machine is not stitching  The hoop 

is moved to the position of the slider 

Color Change

Next to the Current Color Bar is the Color 

Change icon  The color stitching order 

can be adjusted in the same way as done 

in the Stitchout Summary screen: Multi 

Color, Single Color, and Reduce Thread Changes  

The changes you make here override your settings 

from the Stitchout Summary 

Embroidery Information

The 

Embroidery Information Bar shows the current 

stitchout information: current color number, current 

stitch number/total stitch number, total time to 

stitch, and current color time 

Navigation

Return to the Stitchout Summary 

with the Summary icon or to the 

Design Altering Area with the 

Edit button to make additional 

edits  Any changes made in the Summary screen are 

automatically applied to the stitchout 
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Stitch

With the Stitch icon, you can return to a 

specific point in the embroidery design  

This is necessary after a thread break  

When selected, the window appears 

with the number pad and the current stitch place-

ment from the canceled process  Navigate through 

stitches one at a time with the plus (+) and minus (-) 

buttons  Use the upper Multi-function Knob to navi-

gate through stitches in single-stitch increments or 

the bottom knob to navigate in 50-stitch increments 

You can also type in the specific stitch number on 

the number pad (Fig  58)  When the green check-

mark is selected, the window is closed, and the 

hoop position is moved to the input stitch number  If 

a number is outside of range, the position is moved 

to the last position 

When the current stitch has been changed, the 

stitch number button changes to yellow to show it 

has been modified 

High Speed

When High Speed is selected, the 

embroidery will stitch at the fastest 

speed allotted for the current embroidery 

design  Slower speeds are recommended 

for specialty threads or fabrics 

Finish

To complete the design, select “Finish 

Embroidering ”

 

 

Fig. 58 
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CONCLUSION

Now that you have worked through this workbook, you will be familiar with the operation of embroidery 

on your B 990 machine  You can learn more about using your machine by using the instruction manual, the 

Help Center built in to the B 990, the BERNINA Skill Hub, and your local BERNINA dealer 




